instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 21, 2018, 01:27:26 pm


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: Instant Player cluster error  (Read 6772 times)
wolex
Newbie
*
Posts: 3


View Profile
« on: January 05, 2014, 06:40:28 pm »

I just upgraded InstantReality on our CAVE clusters from version 2.2 to 2.3. Firstly, the version I installed for Ubuntu X64 10.04 was from the daily build (InstantReality-Ubuntu-10.04-x64-2.3.0.25462.deb).

I get the following output which looks like some of kind of communication error which led to the termination of the instantclusterservers on the cluster machines. I'm still in the middle of investigating this properly but I'm hoping that someone may shed more light on it.

*************
ENGINE_FILE: "/usr/local/share/instantReality/engines/engine-cave-stereo-head.wrl"
FILES: "/usr/local/share/instantReality/navs/wandjoysticknav.wrl  KelpForestMain.x3d"
Waiting for InstantClusters to start...
...
...
terminate called after throwing an instance of 'Medusa::Thread::Exception'
/usr/local/bin/InstantPlayer-cave: line 111:  3509 Aborted                 /opt/instantReality/bin/InstantPlayer $ENGINE_FILE $FILES
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
XXXX: KILL SERVER
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
XXXX: KILL SERVER
XXXX: KILL SERVER
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
XXXX: KILL SERVER
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
XXXX: KILL SERVER
XXXX: KILL SERVER
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
XXXX: KILL SERVER
LOG:  BinaryDataHandler ReadError: peek got 0 bytes!
XXXX: KILL SERVER
InstantClusterServer: no process found
InstantClusterServer: no process found
InstantClusterServer: no process found
InstantClusterServer: no process found
**************

It crashes after this message. Nothing happens on the cluster displays. Any ideas?
« Last Edit: January 06, 2014, 02:20:52 am by wolex » Logged
tfranke
Administrator
Jr. Member
*****
Posts: 89


View Profile
« Reply #1 on: January 07, 2014, 01:33:35 pm »

Hello wolex,

the error indicates that the server and client are running different versions of the underlying scenegraph system. Can you check that the nodes of your CAVE also have 2.3 running?

Cheers
Logged
wolex
Newbie
*
Posts: 3


View Profile
« Reply #2 on: January 07, 2014, 04:56:06 pm »

Hi,

Yes, I upgraded the nodes as well to the same version. I just downgraded it back to 2.2 and it seems to work fine.

Regards
Logged
wolex
Newbie
*
Posts: 3


View Profile
« Reply #3 on: March 30, 2015, 05:14:32 pm »

I just tried the version 2.4 on our clusters which have all been upgraded to Ubuntu 12.04 and have the same errors again. It works when I downgrade back to 2.2. What could be causing this? I checked and made sure that the InstantPlayer versions were the same. Note that "InstantPlayer --version" gives me an output of 2.3 even though 2.4 was installed. Is there a config file that also need updating?
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines