instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 16, 2018, 10:36:35 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: VisionLib: basic-marker-tracking fatals  (Read 4047 times)
sg
Newbie
*
Posts: 41


View Profile
« on: December 09, 2009, 04:08:19 pm »

we want to test something with the basic-marker-tracker. but apparently the example already has a problem. it works so far, but only with the following nonstop printout. can anyone comprehend the following fatals and warnings? :

WARNING   VisionLib    VisionLibNode::thread: cannot handle image VideoSourceImage
FATAL   VisionLib    SilhouetteExtractorAction: image with no width/height: ConvertedImage
FATAL   VisionLib    PosePlanarAction: no CorrespondencyContainer "World.MarkerTrackerInternals.MarkerTrackerInternalCorr" found or not enough correspondences (0)!!!
WARNING   VisionLib    PoseNLLSAction : input pose NOT valid!!!

thanks and regards
sebastian
Logged
tengelke
Newbie
*
Posts: 3


View Profile
« Reply #1 on: December 13, 2009, 07:33:19 pm »

Hi,

this seems to be a problem with your camera.
The messages indicate, that no valid camera image can be found, thus the whole processing chain will output some errors. Please ensure that you have configured your camera well.
You can verify, if your camera is working within InstantVision.
You have to open IV, add a VideoSource-Action and double click in order to open the action properties. Then you can select the camera and use the generated url within your .pm file, which is basically a simple xml file. Then it should work.
I recommend you the following tutorial:
http://www.instantreality.org/tutorial/camera-setup-with-instantvision/

Thanks and Regards,
Timo
Logged
mzoellner
Jr. Member
**
Posts: 85


View Profile
« Reply #2 on: December 14, 2009, 11:35:17 am »

I have the same problem with RC1 on OS X 10.5. The camera works and is shown. But the console is full of FATALS and WARNINGS and thus InstantPlayer unresponsive.
Logged
tengelke
Newbie
*
Posts: 3


View Profile
« Reply #3 on: December 16, 2009, 12:50:28 pm »

Ok,
I checked the code.
We already removed the fatals (You need to download the latest Dailybuild).
If you want to use the marker tracker from the tutorial, please reconfigure your PM file, which seems to have a problem with the SilhouetteContourExtractor Mode.
So please configure it to mode 0, which is more light invariant anyway.
Therefore open your referred .pm file and:
1. Search for the 'ContourExtractor' Attribute within the ActionConfig element of the MarkerTracker.
2. Change it to the value '0'
3. Save and Close

It should then work much better.
Just for INFO: The Silhouette extractor needs more configuration effort (descibed in:http://www.instantreality.org/tutorial/image-marker-tracking/).

Best regards,
Timo
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines