instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 17, 2018, 02:30:58 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: No ScriptEvaluator for javascript / ecmascript  (Read 3902 times)
Thomas
Newbie
*
Posts: 21


View Profile
« on: July 07, 2014, 04:19:30 pm »

Hi,

we have just tested the dailybuild IR-version InstantReality-OpenSuSE-11.3-x64-2.4.0.25739.rpm. It worked immediately with our SUSE Linux Enterprise Desktop 11 SP3 (x86_64). However, the javascripts, which worked for the older 32bit-versions, are not running anymore. Only the following warning is output:
Code:
WARNING Avalon   Cannot create ScriptEvaluator for Script helloWorldScript
The test scene:
Code:
#X3D V3.0 utf8
Scene {
children [
  DEF helloWorldScript Script {
    url [ "javascript:
      function initialize (value) {
        print('Hello World.');
      }
    "]
  }
]
}

We also tested an older version of IR (InstantReality-OpenSuSE-11.3-x64-2.2.0.24898), but with the same negative result. Do you have any idea how we can solve the problem?

Thanks in advance,
Thomas
Logged
tfranke
Administrator
Jr. Member
*****
Posts: 89


View Profile
« Reply #1 on: July 10, 2014, 12:14:14 pm »

Hello Thomas,

we're investigating the problem. Thanks for reporting the issue.

Cheers
Logged
Thomas
Newbie
*
Posts: 21


View Profile
« Reply #2 on: June 03, 2015, 04:26:10 pm »

Hi Tobias,

have you got any news on this topic?

We have also tested the new version 2.5 of the InstantPlayer for SLES 11.3 64bit, as well as the daily builds and there is still the same problem with the ScriptEvaluator.

Could would please check if you have packed the javascript-libraries properly.

Thanks,
Thomas
Logged
tfranke
Administrator
Jr. Member
*****
Posts: 89


View Profile
« Reply #3 on: June 16, 2015, 04:01:02 pm »

Hey Thomas,

please check version 2.5.1, the problem should be fixed.

Cheers
Logged
Thomas
Newbie
*
Posts: 21


View Profile
« Reply #4 on: June 17, 2015, 04:12:17 pm »

It works now! Thanks a lot.
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines