instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 16, 2018, 10:38:22 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: instant failed to display colors  (Read 3824 times)
nodamei
Newbie
*
Posts: 3


View Profile
« on: June 21, 2014, 09:58:58 pm »

Hi there:
I am using instant player 2.3.0 on OS X. I run a test VRML file from http://math.nist.gov/mcsd/savg/idl2/vrmlsurfa.htm, but the player fails to display colors. All I see are black, but the grid lines are red. Is this the player's problem? How to fix it?

I also generate my own VRML file, the player also fails to display colors.

Thanks
Logged
tfranke
Administrator
Jr. Member
*****
Posts: 89


View Profile
« Reply #1 on: June 23, 2014, 09:59:48 am »

Hey nodamei,

I wasn't able to find the VRML code on the page you've linked. Could you please attach the source code of the VRML (under Additional Options when you post a message)?

Cheers
Logged
nodamei
Newbie
*
Posts: 3


View Profile
« Reply #2 on: June 23, 2014, 01:24:26 pm »

Please click the figure at the upper right corner of that link, you will see the source code Smiley Thanks!
Logged
tfranke
Administrator
Jr. Member
*****
Posts: 89


View Profile
« Reply #3 on: June 23, 2014, 02:51:16 pm »

Hi again,

thanks for the link. So I've extracted the zipped VRML and found that at the very end there is the following code:

Code:
DEF IDL_NAVIGATION NavigationInfo {
headlight FALSE
}

Without a light source, there can't be any colors, so simply write

Code:
DEF IDL_NAVIGATION NavigationInfo {
headlight TRUE
}

and everything should be fine ;-)

Cheers
Logged
nodamei
Newbie
*
Posts: 3


View Profile
« Reply #4 on: June 23, 2014, 03:26:34 pm »

Thanks a lot!!!!! Smiley
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines