instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 17, 2018, 02:31:33 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: get the Viewarea-Node in C#  (Read 1612 times)
psyre
Newbie
*
Posts: 13


View Profile
« on: January 28, 2014, 01:00:44 pm »

Hello,

i can't get access to the Viewarea Node with c#.

I tried it with the following way:

x3d:
 <Engine DEF='engine'>
    <RenderJob DEF='render'>
      <WindowGroup>
        <Window DEF='win' size='1024 768'>
          <Viewarea DEF='viewarea' description='viewarea' grabFrames='1'>
            <Navigator2D DEF='navigator' pickScene='false'/>
          </Viewarea>
        </Window>
      </WindowGroup>
    </RenderJob>
 </Engine>

and in c#:
...
 Vrml.EAI.Node viewarea = browser.GetNode("viewarea");

But always i get the message ' A node with the name "viewarea" does not exist'

I can only get access to all Nodes i have definde between the <Scene> and </Scene> tag.

Can you help me to get access to the Nodes between the <Engine> Tags?

Greetings
Tobias
Logged
yjung
Administrator
Sr. Member
*****
Posts: 260


View Profile
« Reply #1 on: January 28, 2014, 05:31:50 pm »

Try engine::viewarea instead.
Logged
psyre
Newbie
*
Posts: 13


View Profile
« Reply #2 on: January 28, 2014, 05:34:05 pm »

Hello,

at this moment i had found the same way by myself :-)

with engine::viewarea it works perfectly and now i can get the screenshots i want to have.

Thank you for your reply!!

Greetings Tobi
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines