instantreality forum
news: Welcome to the instantreality forums!
Welcome, Guest. Please login or register.
Did you miss your activation email?
March 19, 2018, 05:49:24 am

Login with username, password and session length

Pages: [1]
Author Topic: Installing instantreality .deb package on ubuntu 13.04  (Read 3176 times)
Posts: 1

View Profile
« on: August 26, 2013, 06:09:22 pm »


I tried to install the package:


On a Ubuntu 13.04 system using dpkg and I was confronted with many dependency errors which required unintalling it to fix the apt-get. I installed boost and ssl packages (I have a rather new ubuntu install so these had not been installed yet) but that did not fix the problem.

Is there an up to date build or a repository where I can get the source?

Dr. Kevin Hickerson

I am including a print out of the dpkg output of the problems I encountered:

$ sudo dpkg -i InstantReality-Ubuntu-12.04-x64- 
(Reading database ... 531963 files and directories currently installed.)
Preparing to replace instantrealityplayer (using InstantReality-Ubuntu-12.04-x64- ...
Unpacking replacement instantrealityplayer ...
dpkg: dependency problems prevent configuration of instantrealityplayer:
 instantrealityplayer depends on freeglut3; however:
  Package freeglut3 is not installed.
 instantrealityplayer depends on libalut0 (>= 1.0.1); however:
  Package libalut0 is not installed.
 instantrealityplayer depends on libavahi-compat-libdnssd1 (>= 0.6.16); however:
  Package libavahi-compat-libdnssd1 is not installed.
 instantrealityplayer depends on libavcodec53 (>= 4:0.8-1~) | libavcodec-extra-53 (>= 4:0.8-1~); however:
  Package libavcodec53 is not installed.
  Package libavcodec-extra-53 is not installed.
 instantrealityplayer depends on libavformat53 (>= 4:0.8-1~) | libavformat-extra-53 (>= 4:0.8-1~); however:
  Package libavformat53 is not installed.
  Package libavformat-extra-53 is not installed.
 instantrealityplayer depends on libavutil51 (>= 4:0.8-1~) | libavutil-extra-51 (>= 4:0.8-1~); however:
  Package libavutil51 is not installed.
  Package libavutil-extra-51 is not installed.
 instantrealityplayer depends on libboost-date-time1.46.1 (>= 1.46.1-1); however:
  Package libboost-date-time1.46.1 is not installed.
 instantrealityplayer depends on libboost-filesystem1.46.1 (>= 1.46.1-1); however:
  Package libboost-filesystem1.46.1 is not installed.
 instantrealityplayer depends on libboost-program-options1.46.1 (>= 1.46.1-1); however:
  Package libboost-program-options1.46.1 is not installed.
 instantrealityplayer depends on libboost-python1.46.1 (>= 1.46.1-1); however:
  Package libboost-python1.46.1 is not installed.
 instantrealityplayer depends on libboost-system1.46.1 (>= 1.46.1-1); however:
  Package libboost-system1.46.1 is not installed.
 instantrealityplayer depends on libboost-thread1.46.1 (>= 1.46.1-1); however:
  Package libboost-thread1.46.1 is not installed.
 instantrealityplayer depends on libglade2-0 (>= 1:2.6.1); however:
  Package libglade2-0 is not installed.
 instantrealityplayer depends on libglew1.5 (>=; however:
  Package libglew1.5 is not installed.
 instantrealityplayer depends on libgnome2-0 (>= 2.17.3); however:
  Package libgnome2-0 is not installed.
 instantrealityplayer depends on libgnomeui-0 (>= 2.22.0); however:
  Package libgnomeui-0 is not installed.
 instantrealityplayer depends on libgraphicsmagick++3; however:
  Package libgraphicsmagick++3 is not installed.
 instantrealityplayer depends on libgtkglext1; however:
  Package libgtkglext1 is not installed.
 instantrealityplayer depends on libopenal1 (>= 1:1.13); however:
  Package libopenal1 is not installed.
 instantrealityplayer depends on libswscale2 (>= 4:0.8-1~) | libswscale-extra-2 (>= 4:0.8-1~); however:
  Package libswscale2 is not installed.
  Package libswscale-extra-2 is not installed.
 instantrealityplayer depends on nvidia-cg-toolkit; however:
  Package nvidia-cg-toolkit is not installed.
dpkg: error processing instantrealityplayer (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
Jr. Member
Posts: 89

View Profile
« Reply #1 on: September 17, 2013, 02:25:04 pm »

Hello Dr. Hickerson,

we currently do not support Ubuntu 13 since it's not a long term supported target.

Pages: [1]
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines