instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
April 24, 2018, 04:00:10 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: Decklink Video Card DirectShow-Camera...  (Read 4667 times)
Abaddon
Jr. Member
**
Posts: 79


View Profile
« on: October 05, 2011, 11:38:33 am »

Hi everybody

Even though posts are regulary left unanswered in this forum, I keep trying:
I got a big problem, which I realy need help with!
I bought a Decklink SDI card (a VideoCard). I connected a Sony PMW EX3 (rented) to it, installed and configured everything. By now I can see the live-Image inside the Decklink-own software aswell as Adobe Premiere.
But unfortunately Instant Vision doesnīt recognize the card as an directShow device at all. According to manifacturer the drivers should be completely directShow compatible.
I tried a bunch of software like VLC, AMCap, ManyCam but even though they infact do show me the card as a directShow device(!), They only give a black signal. (which is probably sent by the card).
Has anybody an idea, how I can further test anything or what I could do?
Itīs pretty expensive to rent the camera, so plz answer by today if you can.

thx
Maik
Logged
svkahn
Developer
Newbie
*
Posts: 18


View Profile
« Reply #1 on: October 05, 2011, 07:20:59 pm »

Hi,

unfortunately, there is probably no easy solution for this problem. Once I had a similar problem with another camera (which should have been DirectShow compatible, too) and it didn't work with DirectShow, so I had to implement a custom InstantVision interface module for this camera (it seems that the DirectShow interface works for most cameras, but not for all). As we don't have a Sony PMW EX3, we can't debug into the code to find out more about why this specific camera is not recognized.

Svenja
Logged
Abaddon
Jr. Member
**
Posts: 79


View Profile
« Reply #2 on: October 06, 2011, 10:11:28 am »

Hi

after a realy realy long day yesterday I got it to work. The thing is, after I searched for the bug a long time with the decklink drivers, I had to realize, that the problem was with Instant Reality.
Since I had a Decklink Intensity working just fine about a year ago I started to experiment with older versions, here the results:

-The daily-Build yesterday didnt realize, that there was any directshow device at all.

-The last stable version did in fact see a device but only caught the "default" resolution of 720x486, which is a black screen that the decklink is supposed to send when no camera is connected.

-The Beta 7 shows a directShow device, that in Instant Vision only showed up with 1920x1080xHDYC , which sounded pretty good, but didnīt give any signal either.

-An Daily Build from 20th april 2010(Which I had on another computer by change) was finaly able to start the show in Instant Player with a video signal, even though I cant see it in Instant Vision...
finaly done...

I realy hope, you get to track the problem by all my tests.

cu
Maik


PS: After another read of your post: I think the camera itself cant be a problem, since the signal always goes through the decklink card.
« Last Edit: October 06, 2011, 10:13:31 am by Abaddon » Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines