instantreality forum
news: Welcome to the instantreality forums!
 
*
Welcome, Guest. Please login or register.
Did you miss your activation email?
January 17, 2018, 02:32:33 am


Login with username, password and session length


Pages: [1]
  Print  
Author Topic: PlaneSensor's trackPoint_changed changed behaviour?  (Read 3133 times)
Peter_Pig
Newbie
*
Posts: 23


View Profile
« on: February 26, 2011, 01:40:18 pm »

Hello!

I am observing a different behaviour of PlaneSensor's trackPoint_changed on my current version of InstantPlayer than it was with the previous one.

See attached example.

Whenever the PlaneSensor is nisted inside any sort of transforming node (Transform, Viewspace, ScreenGroup) it seems to send a wrong TrackPoint_changed value the first time it gets active.

Next time it gets active, all is back to normality.

Also I have observed, that TrackPoint_changed is being fired twice with same timestamp, if you click at the sensor having the Player not focused (e.g. the console is focused).

Last one is not a big issue.

Regards,


Peter
Logged
Peter_Pig
Newbie
*
Posts: 23


View Profile
« Reply #1 on: March 27, 2011, 01:06:51 pm »

Hello,

I have installed the last daily build (2.0.0.21442) and my code (see file attached to previous post) is still performing in an odd way:

1) when the planeSensor (green box) is clicked first time, it fires te trackPoint_changed event twice, both times with wrong (at least unexpected for me) values.

2) whilest dragging, the sensor keeps on sending wrong (or unexpected) trackPoint_changed data.

3) once I release the sensor (mouse up) and set it active again (mouse down), it starts sending the correct (expected) trackPoint_changed data.

- Is there something wrong with my code or is it an IP bug?

Regards,

Peter
Logged
Peter_Pig
Newbie
*
Posts: 23


View Profile
« Reply #2 on: April 22, 2011, 12:31:50 pm »

knock, knock ...

trackPoint_changed would be (is) quite a usefull event, if it would (does) deliver reliable data at a first "click".

My experience, so far, is : it stopped delivering reliable data since a few InstantPlayer releases/daily_builds ago.

But I might be wrong.

Please, check one of the following options :

A) there's nothing wrong with trackPoint_changed, just your code is wrong

B) there's something wrong with trackPoint_changed, but it will take another while to fix it

C) nobody cares about trackPoint_changed. This event will not be supported any more by future releases

D) neither nor

Thank's in advance.

Peter


« Last Edit: April 22, 2011, 12:37:47 pm by Peter_Pig » Logged
yjung
Administrator
Sr. Member
*****
Posts: 260


View Profile
« Reply #3 on: April 22, 2011, 08:03:41 pm »

Does this problem still occur with the latest daily build (i.e. not older than about 10 days)? And if so, do you have a little test case?
Logged
Peter_Pig
Newbie
*
Posts: 23


View Profile
« Reply #4 on: April 22, 2011, 10:28:56 pm »

Thank you, Yvonne:

The little test case was attached to my first posting.

Daily build 21506 seems to have fixed the problem.

Probably one should try the daily builds daily  Wink

I wish you  a happy Easter!

Peter
Logged
Pages: [1]
  Print  
 
Jump to:  

Powered by SMF 1.1.15 | SMF © 2011, Simple Machines